PC drops frameslags sometimes?


(Ricky) #1

Hi,

I’ve had a gaming PC for around 6 months now and play things from CS:GO, Mine craft, Rocket League, ARK, etc.

From time to time it seems to drop frames or “lags” but it shouldn’t - it is more than capable of playing these games.

Firstly, is there an easy way to show you guys my exact PC spec(I thought a website did this for you, but couldn’t find it).

Secondly, why is this happening? lol

Thirdly, how do know if I’m using the correct display port on my PC? i.e. am I just using the inbuilt graphics card or am I using the Ge-force 750 Ti?

Any help would be appreciated,

thanks,


(C**t ) #2

What games do you mainly have these issues in? What settings are you using (1080? Ultra/High/Medium etc)? What CPU do you have?

If you download Hardware Monitor it’ll tell you the specs and the temps of the PC, so we can see if the CPU or GPU is thermal throttling(Though Unlikely).

The GPU ports that are horizontal on most cases, they are towards the bottom of the case and away from things like Ethernet USB and 3.5mm Audio, unlike the ones for onboard graphics which are generally next to these ports.


(Sam Connolly) #3

Press windows key + R (to open Run) and type “dxdiag” and hit enter, you could jot the information down from that window in the “System” tab. That’ll tell us processor, OS and RAM. Then if you hope over to the “Display 1” tab next to the “System” tab, you can find what graphics card you have under the "Name: " field. Will also tell us what resolution you’re running on that monitor.

Really easy way to make sure your graphics card is being used, just plug in the DVI / HDMI / Displayport cable into the back of your graphics card instead of your mobo.

Make sure you’re running the latest graphics drivers (as obvious as it may seem, I have no idea how much you know / don’t know about computers so just thought I’d say it anyway). can grab them from here http://www.nvidia.co.uk/Download/index.aspx?lang=en-uk

If you don’t know how to identify what the back of your graphics card looks like here’s a pic of your graphics card at the back: http://images.hardwarecanucks.com/image//skymtl/GPU/GTX-750-TI-REVIEW/GTX-750-TI-REVIEW-4.JPG
So it should have a HDMI port, a DVI port, and another DVI port all side by side, this is what you need to be plugging into.


(Ricky) #4

Prio;

Firstly, the spec goes as follows: -

Windows 7 home premium 64bit
AMD Athalon x4 860k quad core processor (4 cpus) 3.7ghz
8192mb RAM 14642mb available
direct x 11

Nvidea Geforce GTX 750 Ti
4022mb
current display 1920x1080 (60hz)
Monitor: generic PnP monitor

(Not sure if its worth nothing that the monitor i’m using is the Asus VG248QE 24-inch 3D LED Monitor - Black (1920x1080, 80000000:1, 144 Hz, 1ms, DVI Display Port, HDMI))

Also - regarding the pic of the graphics card in your post - mine doesn’t look like this.
I have slot with just the DVI in at the top (my monitor was plugged into this one and I’ve just swapped it over)
The slot I have plugged it into now has 2x hdmi ports and 1x DVI port

(I’ve not played any games since swapping over and posting this)

Hopefully this isn’t mumbo jumbo.


(Xenoscythe) #5

Unrelated note:

Nvidea Geforce GTX 750 Ti
4022mb
current display 1920x1080 (60hz)

(Not sure if its worth nothing that the monitor i’m using is the Asus VG248QE 24-inch 3D LED Monitor - Black (1920x1080, 80000000:1, 144 Hz, 1ms, DVI Display Port, HDMI))

You don’t appear to be running at 144hz, is that purposeful? And are you using DVI, dp or hdmi to connect your monitor?


(Ricky) #6

Link as there are 100’s lol.


(Ricky) #7

Any advise on how to change it?

(i have tried previously and only realised it was 60hz during these posts)


(C**t ) #8

You’ve got the specs now anyway, just use this for temps: https://www.techpowerup.com/realtemp/

How are you changing Monitor refresh rate?
Try going into control panel, then into display settings, then click the refresh rate drop down and choosing 144hz.
or
Right click on your desktop, go to nvidia control panel, then under display click change resolution, then go to the refresh rate drop down and again pick 144hz.


(Xenoscythe) #9

Absolutely! Which windows are you on? -

Windows 10/8.1

  • Search for Display Settings in Cortana/Search bar, click it.
  • On the left side click Display then near the bottom click Advanced Display Settings
  • It will take you to the page where you can change your resolution. At the bottom of the page select Display adapter properties
  • A new window will appear. On one of the tabs at the top select monitor, click it and look for screen refresh rate.

Win 7

  • Hit the windows key and type in Display Settings
  • Choose Change Display Settings
  • It will take you to the page where you can change your resolution. Somewhere it should say Advanced settings, click it.
  • A new window will appear. On one of the tabs at the top select monitor, click it and look for screen refresh rate

(C**t ) #10

Might not be using Dual Link DVI looking at the post regarding where his video output is plugged in. Though if he bought the monitor retail he should have one spare in the box.


(Xenoscythe) #11

@leekyr1 Yep this is pretty key, 144hz is only possible over a Dual Link DVI or display port cable - HDMI and DVI Single Link can only manage 30/48/60hz reliably. So if that option isn’t appearing on your computer, this is the next thing to check!

Its easy to check, you’d be looking for a big block of pins on the cable rather than 2 small blocks of pins eg:


(Ricky) #12

I changed to 144hz and it said incorrect cable, so i can to post and you already had the picture above!

I’ll change that now and try again.


(Ricky) #13

So that’s the 144hz sorted - I changed the cable and it worked.

But…

I put the dual DVI cable into the same slots that the DVI cable was in and the monitor didnt work/register.

Now, I have a DVI port on the vertical near the bottom of the tower, and 2 x DVI ports in the middle/top area (1 x DVI on its own and 1 x DVI with 2 x HDMI ports in the same slot - any ideas???


(C**t ) #14

Is there anychance at all you could post a picture, it would make this a lot easier.


(Dean) #15

All this time I thought DVI dual link required two DVI cables. I feel like an idiot now.


(Sam Connolly) #16

Sounds like you weren’t plugged into the graphics card to be honest, so try out a few games and let us know how it goes :slight_smile: That’d be best case scenario that fixes it. If not just shout up again and maybe there’s some deeper problem somewhere.

The vertical DVI port is almost certainly your motherboards, unless you have a tower which isn’t the most common shape. So your motherboard sits vertically in your tower, and your graphics card plugs into your motherboard but sits perpendicularly (so it would be horizontal, in most cases).

You set this PC yourself or was it set up for you? The times I’ve set PC’s up myself and found this issue of no signal are when I’ve been a melon and forgotten to plug the power cables into the graphics card. It’s worth checking, especially if you’ve set it up yourself. Mistakes happen and it’s easy to forget to plug it in